summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Wellnhofer <wellnhofer@aevum.de>2014-11-16 21:56:49 +0100
committerNick Wellnhofer <wellnhofer@aevum.de>2014-11-16 22:43:04 +0100
commit675b92aa6b6c8124c8ccf9535e338fd37b8b9977 (patch)
treef3201e9ceb6fab30db8c97bcc01812ef341f97b9 /src/CMakeLists.txt
parent52045957a87f2c86f61f2054cafbebe050a1299b (diff)
Move inline function definitions to header files
Inline functions must be defined in header files in order to be inlined in other compilation units. This also fixes the MSVC build where out-of-line versions weren't created and allows to remove the -fgnu89-inline flag.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c399713..6f78a26 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -125,10 +125,6 @@ if(MSVC)
set(CMAKE_C_FLAGS "/TP")
endif()
-if(CMAKE_COMPILER_IS_MINGW)
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -fgnu89-inline")
-endif(CMAKE_COMPILER_IS_MINGW)
-
if($ENV{TIMER})
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DTIMER=1")
endif($ENV{TIMER})