summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2015-05-29 11:09:48 -0700
committerJohn MacFarlane <jgm@berkeley.edu>2015-05-29 11:09:48 -0700
commite5d216b9190bb0ca6f33e175931630e7aa9bd430 (patch)
tree44196cf7204aade8acfce11f76551be0831e3923 /src/CMakeLists.txt
parent678bdab4a4421e64f7c36991a098ae6db730140b (diff)
Revert "Ubsan: add -fsanitize=undefined to link flags too."
This reverts commit 678bdab4a4421e64f7c36991a098ae6db730140b. This commit led to two -fsanitized=undefined in the same linker invocation.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a38393c..f27186e 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -167,5 +167,4 @@ endif($ENV{TIMER})
if(CMAKE_BUILD_TYPE STREQUAL "Ubsan")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fsanitize=undefined")
- set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -fsanitize=undefined")
endif() \ No newline at end of file