summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2016-03-28 15:28:00 -0700
committerJohn MacFarlane <jgm@berkeley.edu>2016-03-28 15:28:00 -0700
commit6e8c3f6148ec586fd4cc5c89c644422dd6ec33d5 (patch)
tree7ac04d30250616a32835c3d2995af5f499c4d9db /test/CMakeLists.txt
parentdf5eed3b7fce2853e331c7de5294668c5b376334 (diff)
parent848ca96890db32eb98d44765886853bed626a4ee (diff)
Merge pull request #120 from nwellnhof/regression-tests
Add first regression tests
Diffstat (limited to 'test/CMakeLists.txt')
-rwxr-xr-xtest/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index d537ab5..fbfd1d0 100755
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -53,6 +53,13 @@ IF (PYTHONINTERP_FOUND)
"${ROUNDTRIP} ${CMAKE_CURRENT_BINARY_DIR}/../src/cmark"
)
+ add_test(regressiontest_executable
+ ${PYTHON_EXECUTABLE}
+ "${CMAKE_CURRENT_SOURCE_DIR}/spec_tests.py" "--no-normalize" "--spec"
+ "${CMAKE_CURRENT_SOURCE_DIR}/regression.txt" "--program"
+ "${CMAKE_CURRENT_BINARY_DIR}/../src/cmark"
+ )
+
ELSE(PYTHONINTERP_FOUND)